diff configure.in @ 2033:27437eeb8c8d

detect both gtk2 and 3 in autoconf
author Vladimir Nadvornik <nadvornik@suse.cz>
date Fri, 10 Aug 2012 22:51:57 +0200
parents 26dfd7a4d130
children ad2e0cac775c
line wrap: on
line diff
--- a/configure.in	Sun Aug 12 22:07:51 2012 +0200
+++ b/configure.in	Fri Aug 10 22:51:57 2012 +0200
@@ -190,7 +190,13 @@
 fi
 
 AM_PATH_GLIB_2_0(2.4.0,,AC_MSG_ERROR(GLIB >= 2.4.0 not installed.))
-AM_PATH_GTK_2_0(2.4.0,,AC_MSG_ERROR(GTK+ >= 2.4.0 not installed.))
+AC_ARG_ENABLE([gtk3], AC_HELP_STRING([--disable-gtk3], [use gtk2 instead of gtk3]),[gtk3="${enableval}"], [gtk3=m4_ifdef([AM_PATH_GTK_3_0], [yes], [no])])
+
+if test x$gtk3 == xyes; then
+    m4_ifdef([AM_PATH_GTK_3_0], [AM_PATH_GTK_3_0(3.0.0,,AC_MSG_ERROR(GTK+ >= 3.0.0 not installed.))])
+else
+    m4_ifdef([AM_PATH_GTK_2_0], [AM_PATH_GTK_2_0(2.12.0,,AC_MSG_ERROR(GTK+ >= 2.12.0 not installed.))])
+fi
 
 threads="auto"
 AC_ARG_ENABLE([threads],