diff configure.in @ 2608:62da56d27277

Fix the implicit-fallthrough stuff in code First, this flag was not supported by older gcc. And second and more important, there _was_ a bug with a lost break in 9643a2546bcc. Combined with a unreachable code segment.
author Klaus Ethgen <Klaus@Ethgen.de>
date Sun, 17 Sep 2017 15:53:47 +0100
parents 71e7f2a9b52c
children 0dc5dd177e54
line wrap: on
line diff
--- a/configure.in	Sun Sep 17 15:12:21 2017 +0100
+++ b/configure.in	Sun Sep 17 15:53:47 2017 +0100
@@ -18,7 +18,7 @@
 AC_INIT([geeqie], m4_esyscmd_s(git rev-parse --quiet --verify --short HEAD), [geeqie-devel@lists.sourceforge.net], [], [http://www.geeqie.org/])
 
 # Add -Werror to the default CFLAGS
-CFLAGS+=" -Werror -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=implicit-fallthrough -Wno-error=return-type"
+CFLAGS+=" -Werror -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=return-type"
 
 # Check for rightly dirs
 AC_CONFIG_SRCDIR([src/main.c])