diff src/icons/Makefile.am @ 2860:b20a96b979a3

Fix #437: Delete to standard Trash directory https://github.com/BestImageViewer/geeqie/issues/437 The method of file deletion is changed. The Preferences/Behaviour option "Safe delete" is removed. The user has the option to choose Geeqie-defined trash bin or system-defined trash bin as the normal mode - set in Preferences/Behaviour. Menus have two entries: Move to trash and Permanent delete. The Delete key moves to trash; shift-Delete deletes permanently. Both Move to trash and Permanent delete have user-selectable confirmation, set in Preferences/Behaviour. This means the function of the Delete key is changed from Permanent delete to Move to trash, which is a fail-safe change.
author Colin Clark <colin.clark@cclark.uk>
date Sat, 03 Nov 2018 17:53:31 +0000
parents e88128f85953
children
line wrap: on
line diff
--- a/src/icons/Makefile.am	Thu Nov 01 13:59:03 2018 +0000
+++ b/src/icons/Makefile.am	Sat Nov 03 17:53:31 2018 +0000
@@ -46,7 +46,8 @@
 	icon_rotate_180.png \
 	icon_mirror.png \
 	icon_flip.png \
-	icon_original.png
+	icon_original.png \
+	icon_trash.png
 
 ICONS_INLINE_PAIRS = \
 	folder_closed		$(srcdir)/folder_closed.png	\
@@ -91,7 +92,8 @@
 	icon_rotate_180	$(srcdir)/icon_rotate_180.png \
 	icon_mirror	$(srcdir)/icon_mirror.png \
 	icon_flip	$(srcdir)/icon_flip.png \
-	icon_original	$(srcdir)/icon_original.png
+	icon_original	$(srcdir)/icon_original.png \
+	icon_trash	$(srcdir)/icon_trash.png
 
 icons_inline.h: $(ICONS_INLINE) Makefile.in
 	@sh -ec "echo '/* Auto generated file, do not edit */'; echo; \