diff configure.in @ 2100:b2d8adb561e3

Add support for LCMS2 Both LCMS1 and LCMS2 are supported.
author Michal Čihař <mcihar@suse.cz>
date Tue, 21 Aug 2012 11:40:19 +0200
parents 034e50486d27
children 59b559f747a7
line wrap: on
line diff
--- a/configure.in	Mon Aug 20 22:42:33 2012 +0200
+++ b/configure.in	Tue Aug 21 11:40:19 2012 +0200
@@ -290,14 +290,22 @@
     [liblcms=$enableval], [liblcms=auto])
 
 if test "x${liblcms}" != "xno"; then
-  PKG_CHECK_MODULES(LCMS, [lcms >= 1.14],
+  PKG_CHECK_MODULES(LCMS, [lcms2 >= 2.0],
     [
       HAVE_LCMS=yes
       AC_DEFINE(HAVE_LCMS, 1, [define to enable use of color profiles with lcms])
+      AC_DEFINE(HAVE_LCMS2, 1, [lcms2 is used])
     ],
     [
-      HAVE_LCMS=no
-      AC_MSG_WARN([$LCMS_PKG_ERRORS])
+    PKG_CHECK_MODULES(LCMS, [lcms >= 1.14],
+      [
+        HAVE_LCMS=yes
+        AC_DEFINE(HAVE_LCMS, 1, [define to enable use of color profiles with lcms])
+      ],
+      [
+        HAVE_LCMS=no
+        AC_MSG_WARN([$LCMS_PKG_ERRORS])
+      ])
     ])
 else
   HAVE_LCMS=disabled