log th_util.c @ 457:85fa3d333556

age author description
Tue, 02 Jan 2018 23:09:29 +0200 Matti Hamalainen Actually, revert the boolean changes .. meh.
Tue, 02 Jan 2018 22:56:03 +0200 Matti Hamalainen Break backwards compatibility by renaming BOOL, TRUE and FALSE to lowercase.
Thu, 12 Oct 2017 17:12:50 +0300 Matti Hamalainen Get rid of trailing whitespace.
Wed, 17 Feb 2016 14:20:36 +0200 Matti Hamalainen Split data structures (linked lists, growbufs, ringbufs, etc.) code into th_datastruct.[ch] module.
Thu, 11 Feb 2016 20:26:47 +0200 Matti Hamalainen Rename th_free_r() to th_free_r_real() and #define a macro wrapper for
Thu, 11 Feb 2016 16:42:43 +0200 Matti Hamalainen 100L.
Thu, 11 Feb 2016 16:42:00 +0200 Matti Hamalainen Define some argument identifiers in function prototypes and rename some arguments.
Thu, 11 Feb 2016 16:10:31 +0200 Matti Hamalainen Add new function th_free_r(void **ptr) that calls th_free(*ptr) and sets *ptr to NULL.
Mon, 02 Mar 2015 01:46:31 +0200 Matti Hamalainen Adjust program banner printing.
Mon, 09 Feb 2015 18:52:56 +0200 Matti Hamalainen Actually, move th_print_wrap() to th_string module.
Mon, 09 Feb 2015 18:41:00 +0200 Matti Hamalainen Make th_print_wrap() function public and move the code to th_util.
Sat, 07 Feb 2015 01:39:20 +0200 Matti Hamalainen Merged.
Sat, 07 Feb 2015 01:37:58 +0200 Matti Hamalainen Rename qringbuf_t to th_ringbuf_t.
Sat, 07 Feb 2015 01:37:11 +0200 Matti Hamalainen Add new utility function for linked lists, th_llist_free_func_node().
Sat, 07 Feb 2015 00:33:16 +0200 Matti Hamalainen Cosmetic.
Fri, 06 Feb 2015 23:04:08 +0200 Matti Hamalainen Rename qlist_t doubly linked list structure to th_llist_t.
Thu, 01 Jan 2015 09:22:27 +0200 Matti Hamalainen Merge.
Thu, 01 Jan 2015 09:22:08 +0200 Matti Hamalainen Update copyrights.
Sun, 07 Dec 2014 20:49:10 +0200 Matti Hamalainen Implement terminal width.
Sun, 22 Jun 2014 07:23:54 +0300 Matti Hamalainen Cosmetics.
Sun, 22 Jun 2014 03:34:00 +0300 Matti Hamalainen Use th_malloc0() where appropriate.
Sun, 22 Jun 2014 01:25:35 +0300 Matti Hamalainen Use void* instead of uint8_t* in th_growbuf_put_str()
Sat, 21 Jun 2014 23:11:36 +0300 Matti Hamalainen More work on growbuf stuff.
Sat, 21 Jun 2014 22:44:56 +0300 Matti Hamalainen More functions for growbuf.
Sat, 21 Jun 2014 20:42:06 +0300 Matti Hamalainen Remove th_growbuf, move to th_util.
Tue, 27 May 2014 07:28:59 +0300 Matti Hamalainen Rename th_get_errno() to th_get_error(), it's more appropriate since it does
Sun, 25 May 2014 01:01:31 +0300 Matti Hamalainen Add th_errno_to_error().
Sun, 25 May 2014 01:01:13 +0300 Matti Hamalainen Remove th_memset().
Thu, 22 May 2014 03:29:08 +0300 Matti Hamalainen Add error handling stuff.
Wed, 21 May 2014 21:40:40 +0300 Matti Hamalainen Make th_llist_delete_node_fast() public.