diff src/Makefile.am @ 1:183e7cbc1036

Initial revision
author Matti Hamalainen <ccr@tnsp.org>
date Tue, 03 Jun 2003 10:23:04 +0000
parents
children 5b7009eef767
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/Makefile.am	Tue Jun 03 10:23:04 2003 +0000
@@ -0,0 +1,23 @@
+# Generated libraries
+lib_LTLIBRARIES = libsid.la
+
+# Generals
+
+CFLAGS   = -O2 -W -Wall -I$(top_builddir) -I$(top_srcdir) -I$(includedir) -D_REENTRANT @GTK_CFLAGS@ @SIDPLAY_CFLAGS@ -lstdc++
+CXXFLAGS = $(CFLAGS)
+LIBS     = -lsidplay
+
+libsid_la_LDFLAGS = -module -avoid-version
+libsid_la_LIBADD  = @GTK_LIBS@ @PTHREAD_LIBS@
+
+# Plugin sources
+libsid_la_SOURCES =	\
+	xmms-sid.cc	\
+	xs_init.c	\
+	xs_config.c	\
+	xs_fileinfo.cc	\
+	xs_stil.c	\
+	xs_about.c	\
+	xmms-sid.h	\
+	xmms-sid-logo.xpm
+