diff configure.ac @ 800:1fe6005ed58c

Make it so that both libSIDPlay2 and libSIDPlay-FP can co-exist, though not at run-time, but either one can be chosen via --with-/--without- configure options.
author Matti Hamalainen <ccr@tnsp.org>
date Wed, 07 Nov 2012 11:58:46 +0200
parents 3e305ce076e8
children 7a716a3972f3
line wrap: on
line diff
--- a/configure.ac	Wed Nov 07 11:26:31 2012 +0200
+++ b/configure.ac	Wed Nov 07 11:58:46 2012 +0200
@@ -97,7 +97,7 @@
 
 
 xs_have_sidplay2_api=""
-XS_ARG_WITH([sidplay2], [libSIDPlay2], [XS_PATH_LIBSIDPLAY2])
+XS_ARG_WITH([sidplayfp], [libSIDPlayFP], [XS_PATH_LIBSIDPLAYFP])
 
 if test "x$xs_have_sidplayfp" = "xyes"; then
 	xs_have_sidplay2_api="(FP)"
@@ -108,7 +108,9 @@
 	AC_DEFINE([HAVE_RESID_BUILDER])
 	AC_DEFINE([HAVE_RESID_FP_BUILDER])
 
-elif test "x$xs_have_sidplay2" = "xyes"; then
+else
+XS_ARG_WITH([sidplay2], [libSIDPlay2], [XS_PATH_LIBSIDPLAY2])
+if test "x$xs_have_sidplay2" = "xyes"; then
 	xs_have_sidplay2_api="(non-COMI)"
 	xs_have_sidplay2_lib="yes"
 	AC_DEFINE([HAVE_SIDPLAY2])
@@ -126,6 +128,7 @@
 
 	AC_LANG_POP([C++])
 fi
+fi
 
 
 dnl ***