diff configure.ac @ 991:34259889b2b1 dev-0_9_1

Add support for libSIDPlay-FP v1.1.x.
author Matti Hamalainen <ccr@tnsp.org>
date Fri, 11 Oct 2013 14:37:20 +0300
parents ea3889c40011
children 9feda7db56d7
line wrap: on
line diff
--- a/configure.ac	Fri Oct 11 13:47:41 2013 +0300
+++ b/configure.ac	Fri Oct 11 14:37:20 2013 +0300
@@ -22,7 +22,8 @@
 AH_TEMPLATE([HAVE_SIDPLAY1], [Define if you have and want to use libSIDPlay 1.])
 AH_TEMPLATE([HAVE_SIDPLAY2], [Define if you have and want to use libSIDPlay 2.])
 AH_TEMPLATE([HAVE_SIDPLAYFP], [Define if you have and want to use libSIDPlay2-FP http://sourceforge.net/projects/sidplay-residfp/])
-AH_TEMPLATE([HAVE_SIDPLAYFP_V1], [Define if you are using v1.0.0 API of libSIDPlay2-FP.])
+AH_TEMPLATE([HAVE_SIDPLAYFP_V10], [Define if you are using v1.0.x API of libSIDPlay2-FP.])
+AH_TEMPLATE([HAVE_SIDPLAYFP_V11], [Define if you are using v1.1.x API of libSIDPlay2-FP.])
 AH_TEMPLATE([HAVE_THEMETUNE], [Define if you want to build code to play XMMS-SID theme SID-tune. The tune needs to be installed too, though.])
 AH_TEMPLATE([DEBUG], [Define if you wish to enable debug output to terminal.])
 
@@ -134,8 +135,11 @@
 	AC_DEFINE([HAVE_HARDSID_BUILDER])
 	AC_DEFINE([HAVE_RESID_BUILDER])
 	AC_DEFINE([HAVE_RESID_FP_BUILDER])
-	if test "x$xs_pkg_sidplayfp_v1" = "xyes"; then
-		AC_DEFINE([HAVE_SIDPLAYFP_V1])
+	if test "x$xs_pkg_sidplayfp_v10" = "xyes"; then
+		AC_DEFINE([HAVE_SIDPLAYFP_V10])
+	fi
+	if test "x$xs_pkg_sidplayfp_v11" = "xyes"; then
+		AC_DEFINE([HAVE_SIDPLAYFP_V11])
 	fi
 dnl fi
 else
@@ -226,15 +230,3 @@
 	Translations (i18n/nls)       : $USE_NLS
 	Debugging enabled             : $xs_enable_debug
 ])
-
-if test "x$xs_pkg_sidplayfp_v1" = "xyes"; then
-	echo ""
-	echo "WARNING! You seem to be using libSIDPlayFP v1.x, which is, at the"
-	echo "time of this release, still in alpha state. The API may not be compatible."
-	echo "If you experience any problems, downgrade to libSIDPlayFP 0.3.7 or 0.3.5."
-	echo ""
-	echo "Or check if there are any newer releases of XMMS-SID that might support"
-	echo "the newer versions of libSIDPlayFP."
-	echo ""
-	echo "Or just use plain old libSIDPlay2."
-fi