diff Makefile.am @ 472:3f02945a0c48

Cleanups.
author Matti Hamalainen <ccr@tnsp.org>
date Thu, 25 Jan 2007 05:58:05 +0000
parents a5ebf8595154
children 34d48e513419
line wrap: on
line diff
--- a/Makefile.am	Thu Jan 25 03:51:01 2007 +0000
+++ b/Makefile.am	Thu Jan 25 05:58:05 2007 +0000
@@ -2,16 +2,23 @@
 ### Makefile.am for XMMS-SID
 ###
 # Require latest automake
-AUTOMAKE_OPTIONS = 1.7
+AUTOMAKE_OPTIONS = 1.9
 
 PACKAGE = @PACKAGE@
 VERSION = @VERSION@
 
+themetune = Kummatti_City.sid
+libxmmssiddir = $(pkgdatadir)
+libxmmssid_DATA = $(themetune)
+
+SUBDIRS = m4 po
+ACLOCAL_AMFLAGS = -I m4
+
 # Personal XMMS directory in user's home
 USERHOMEPREFIX = ~/.xmms/Plugins
 
 # All the rest of the distributed files
-EXTRA_DIST = mkinstalldirs 				\
+EXTRA_DIST = mkinstalldirs 		\
 	FAQ				\
 	BUGS				\
 	THANKS				\
@@ -57,7 +64,10 @@
 lib_LTLIBRARIES = libxmmssid.la
 
 # Generals
-AM_CFLAGS   = -W -Wall -D_REENTRANT @XMMS_CFLAGS@ @SIDPLAY1_INCLUDES@ @SIDPLAY2_INCLUDES@ @BUILDERS_INCLUDES@
+AM_CFLAGS   = -W -Wall -D_REENTRANT @XMMS_CFLAGS@ @SIDPLAY1_INCLUDES@	\
+		@SIDPLAY2_INCLUDES@ @BUILDERS_INCLUDES@			\
+		-DTHEMETUNE_FILE="\"$(pkgdatadir)/$(themetune)\""
+
 AM_CXXFLAGS = $(AM_CFLAGS)
 
 libxmmssid_la_LDFLAGS = -module -avoid-version @BUILDERS_LDFLAGS@
@@ -84,9 +94,3 @@
 	src/xs_sidplay2.cc	src/xs_sidplay2.h	\
 	src/xmms-sid.c		src/xmms-sid.h
 
-libxmmssiddir = $(pkgdatadir)
-libxmmssid_DATA = @THEMETUNE_FILE@
-
-SUBDIRS = m4 po
-
-ACLOCAL_AMFLAGS = -I m4