diff configure.ac @ 823:6f7fada39665

Add -fstack-protector-all to debug mode CC options.
author Matti Hamalainen <ccr@tnsp.org>
date Wed, 07 Nov 2012 16:28:22 +0200
parents 81b3fe49ad54
children 517c235cafb4
line wrap: on
line diff
--- a/configure.ac	Wed Nov 07 16:09:36 2012 +0200
+++ b/configure.ac	Wed Nov 07 16:28:22 2012 +0200
@@ -80,6 +80,8 @@
 ], [xs_enable_debug=no])
 if test "x$xs_enable_debug" = "xyes"; then
 	AC_DEFINE([DEBUG])
+	CFLAGS="$CFLAGS -fstack-protector-all"
+	CXXFLAGS="$CXXFLAGS -fstack-protector-all"
 fi