diff configure.ac @ 745:9dc5378cc806

Remove XMMS_EXTRA stuff, as we require XMMS 1.2.10+ now.
author Matti Hamalainen <ccr@tnsp.org>
date Mon, 05 Nov 2012 17:24:49 +0200
parents c7fa50576c70
children c8be6b069eec
line wrap: on
line diff
--- a/configure.ac	Mon Nov 05 17:24:16 2012 +0200
+++ b/configure.ac	Mon Nov 05 17:24:49 2012 +0200
@@ -19,7 +19,6 @@
 dnl *** Define some templates
 dnl ***
 AH_TEMPLATE([HAVE_SONG_POSITION], [Define if you have XMMS patched with the songpos patch.])
-AH_TEMPLATE([HAVE_XMMSEXTRA], [Define if you have XMMS version 1.2.5 or later and you want XMMS-SID to support some extra features.])
 AH_TEMPLATE([HAVE_SIDPLAY1], [Define if you have and want to use libSIDPlay 1])
 AH_TEMPLATE([HAVE_SIDPLAY2], [Define if you have and want to use libSIDPlay 2])
 AH_TEMPLATE([HAVE_SIDPLAY2_FP], [Define if you have and want to use libSIDPlay 2-FP http://sourceforge.net/projects/sidplay-residfp/])
@@ -157,18 +156,11 @@
 dnl ***
 dnl *** Check XMMS version
 dnl ***
-AM_PATH_XMMS([1.2.0],, [
-AC_MSG_ERROR([*** XMMS >= 1.2.0 not found. You need XMMS v1.2.0 or later to use XMMS-SID plugin.])
+AM_PATH_XMMS([1.2.10],, [
+ 	AC_MSG_ERROR([*** XMMS >= 1.2.10 not found. You need XMMS v1.2.10 or later to use XMMS-SID plugin.])
 ])
 libdir="$XMMS_INPUT_PLUGIN_DIR"
 
-XMMS_TEST_VERSION([$XMMS_VERSION], [1.2.5], [
-	AC_DEFINE([HAVE_XMMSEXTRA])
-	xs_have_xmmsextra="yes"
-], [
-	xs_have_xmmsextra="no"
-])
-
 
 dnl ***
 dnl *** And finally, output the all generatable files!
@@ -188,7 +180,6 @@
 	$PACKAGE_STRING has been configured successfully:
 
 	Installation directory        : $libdir
-	XMMS >= v1.2.5 extra features : $xs_have_xmmsextra
 	Song-position patch           : $xs_have_songpos
 	libSIDPlay 1 support          : $xs_have_sidplay1
 	libSIDPlay 2 support          : $xs_have_sidplay2_lib $xs_have_sidplay2_api