diff configure.ac @ 838:ae1f6418d093

libSIDPlay2-FP backend interface is now in a separate module. Configuration related things still pending.
author Matti Hamalainen <ccr@tnsp.org>
date Thu, 08 Nov 2012 21:24:38 +0200
parents 2531396c2718
children 29f3c3f29c0d
line wrap: on
line diff
--- a/configure.ac	Thu Nov 08 20:58:45 2012 +0200
+++ b/configure.ac	Thu Nov 08 21:24:38 2012 +0200
@@ -21,7 +21,8 @@
 AH_TEMPLATE([HAVE_SONG_POSITION], [Define if you have XMMS patched with the songpos patch.])
 AH_TEMPLATE([HAVE_SIDPLAY1], [Define if you have and want to use libSIDPlay 1.])
 AH_TEMPLATE([HAVE_SIDPLAY2], [Define if you have and want to use libSIDPlay 2.])
-AH_TEMPLATE([HAVE_SIDPLAY2_FP], [Define if you have and want to use libSIDPlay 2-FP http://sourceforge.net/projects/sidplay-residfp/])
+AH_TEMPLATE([HAVE_SIDPLAYFP], [Define if you have and want to use libSIDPlay2-FP http://sourceforge.net/projects/sidplay-residfp/])
+AH_TEMPLATE([HAVE_SIDPLAYFP_V1], [Define if you are using v1.0.0 API of libSIDPlay2-FP.])
 AH_TEMPLATE([HAVE_THEMETUNE], [Define if you want to build code to play XMMS-SID theme SID-tune. The tune needs to be installed too, though.])
 AH_TEMPLATE([DEBUG], [Define if you wish to enable debug output to terminal.])
 
@@ -116,30 +117,32 @@
 fi
 
 
-xs_have_sidplay2_api=""
 XS_ARG_WITH([sidplayfp], [libSIDPlayFP], [XS_PATH_LIBSIDPLAYFP])
+	if test "x$xs_pkg_sidplayfp_v1" = "xyes"; then
+		AC_DEFINE([HAVE_SIDPLAYFP_V1])
+		xs_have_sidplay2_api="(FP v1.0 (alpha) API)"
+	fi
+fi
 
 if test "x$xs_have_sidplayfp" = "xyes"; then
-	xs_have_sidplay2_api="(FP)"
-	xs_have_sidplay2_lib="yes"
-	AC_DEFINE([HAVE_SIDPLAY2])
-	AC_DEFINE([HAVE_SIDPLAY2_FP])
+	AC_DEFINE([HAVE_SIDPLAYFP])
 	AC_DEFINE([HAVE_HARDSID_BUILDER])
 	AC_DEFINE([HAVE_RESID_BUILDER])
 	AC_DEFINE([HAVE_RESID_FP_BUILDER])
 
-else
+xs_have_sidplay2_api=""
 XS_ARG_WITH([sidplay2], [libSIDPlay2], [XS_PATH_LIBSIDPLAY2])
 if test "x$xs_have_sidplay2" = "xyes"; then
-	xs_have_sidplay2_api="(non-COMI)"
-	xs_have_sidplay2_lib="yes"
+	xs_have_sidplay2_api="(old non-COMI)"
 	AC_DEFINE([HAVE_SIDPLAY2])
 
 	AC_LANG_PUSH([C++])
 	
 	XS_BUILDERS_CHECK
         xs_builders_available="no"
+	dnl This is a faux check, to satisfy things
 	XS_BUILDERS_FIND([reSID_FP], [residfp-builder], [residfp.h], [ReSIDfpBuilder])
+	dnl These checks are real
 	XS_BUILDERS_FIND([reSID], [resid-builder], [resid.h], [ReSIDBuilder])
 	XS_BUILDERS_FIND([HardSID], [hardsid-builder], [hardsid.h], [HardSID])
 	if test "x$xs_builders_available" = "xno"; then
@@ -148,14 +151,13 @@
 
 	AC_LANG_POP([C++])
 fi
-fi
 
 
 dnl ***
 dnl *** Check if we have some emulator library available?
 dnl ***
 if test "x$xs_have_sidplay1" != "xyes" -a "x$xs_have_sidplay2" != "xyes" -a "x$xs_have_sidplayfp" != "xyes"; then
-	AC_MSG_ERROR([Either libSIDPlay1 or libSIDPlay2/libSIDPlay-FP is required! Please read INSTALL for more information!])
+	AC_MSG_ERROR([Either libSIDPlay1, libSIDPlay2 or libSIDPlay2-FP is required! Please read INSTALL for more information!])
 fi
 
 
@@ -208,8 +210,9 @@
 	Plugin installation directory : $libdir
 	Song-position patch           : $xs_have_songpos
 	libSIDPlay 1 support          : $xs_have_sidplay1
-	libSIDPlay 2 support          : $xs_have_sidplay2_lib $xs_have_sidplay2_api
+	libSIDPlay 2 support          : $xs_have_sidplay2 $xs_have_sidplay2_api
 	    Included builders         : $xs_builders
+	libSIDPlay 2-FP support       : $xs_have_sidplayfp
 	XMMS-SID theme SID-tune       : $xs_have_themetune
 	Translations (i18n/nls)       : $USE_NLS
 	Debugging enabled             : $xs_enable_debug