diff Makefile.am @ 675:d1b32e981e73

Generate a ChangeLog.
author Matti Hamalainen <ccr@tnsp.org>
date Fri, 09 May 2008 20:09:08 +0300
parents c1f10da42684
children 0e879fb48b48
line wrap: on
line diff
--- a/Makefile.am	Sun Apr 27 03:56:57 2008 +0300
+++ b/Makefile.am	Fri May 09 20:09:08 2008 +0300
@@ -33,10 +33,10 @@
 
 # Update changelog
 update:
-	if test -e ".svn"; then svn update; fi
+	if test -e ".hg"; then hg update tip; fi
 
 .changelog: update
-	if test -e ".svn"; then svn2cl --stdout --group-by-day --strip-prefix xmms-sid/trunk/ | sed "s/  ccr$$/  Matti Hämäläinen (ccr\/TNSP)  <ccr@tnsp.org>/" > ChangeLog; fi
+	if test -e ".hg"; then hg2cl; fi
 	touch $@
 
 ChangeLog: .changelog