diff configure.in @ 200:ec8b735f5418

Support for libNanoSID dropped.
author Matti Hamalainen <ccr@tnsp.org>
date Thu, 19 Aug 2004 19:06:02 +0000
parents bd7375970826
children e776df0ee706
line wrap: on
line diff
--- a/configure.in	Wed Aug 18 15:23:05 2004 +0000
+++ b/configure.in	Thu Aug 19 19:06:02 2004 +0000
@@ -20,7 +20,6 @@
 AH_TEMPLATE([HAVE_XMMSEXTRA],[Define if you have XMMS version 1.2.5 or later and you want XMMS-SID to support some extra features.])
 AH_TEMPLATE([HAVE_SIDPLAY1],[Define if you have and want to use libSIDPlay 1])
 AH_TEMPLATE([HAVE_SIDPLAY2],[Define if you have and want to use libSIDPlay 2])
-AH_TEMPLATE([HAVE_NANOSID],[Define if you have and want to use libNanoSID])
 AH_TEMPLATE([HAVE_RESID_BUILDER],[Define if you have reSID with libSIDPlay 2])
 AH_TEMPLATE([HAVE_HARDSID_BUILDER],[Define if you have HardSID with libSIDPlay 2])
 
@@ -144,43 +143,6 @@
 
 
 dnl ***
-dnl *** libNanoSID options
-dnl ***
-AC_ARG_WITH(nanosid,
-[
-  --with-nanosid=PREFIX   Enable NanoSID with PREFIX],
-[
-if test "$withval" = yes; then
-xs_nanosid=yes
-xs_nanosid_library=""
-xs_nanosid_includes=""
-else
-if test "$withval" = no; then
-	xs_nanosid=no
-	else
-	xs_nanosid=yes
-	xs_nanosid_includes="$withval/include"
-	xs_nanosid_library="$withval/lib"
-	fi
-fi
-],[
-xs_nanosid=xtry
-xs_nanosid_library=""
-xs_nanosid_includes=""
-])
-
-
-AC_ARG_WITH(nanosid-inc,
-[  --with-nanosid-inc=DIR    Where the NanoSID headers are located],
-[xs_nanosid_includes="$withval"],)
-
-
-AC_ARG_WITH(sidplay1-lib,
-[  --with-nanosid-lib=DIR    Where the NanoSID library is installed],
-[xs_nanosid_library="$withval"],)
-
-
-dnl ***
 dnl *** Determine if libraries are wanted and available
 dnl ***
 OPT_SIDPLAY1="no"
@@ -225,31 +187,12 @@
 fi
 
 
-OPT_NANOSID="no"
-if test "$xs_nanosid" = xtry; then
-	XS_PATH_LIBNANOSID
-	else
-	if test "$xs_nanosid" = yes; then
-		XS_PATH_LIBNANOSID
-		if test "$xs_have_nanosid" = no; then
-		AC_MSG_ERROR([libNanoSID library and/or headers were not found!])
-		fi
-	fi
-fi
-if test "$xs_have_nanosid" = yes; then
-	AC_DEFINE(HAVE_NANOSID)
-	OPT_NANOSID="yes"
-fi
-
-
 dnl ***
 dnl *** Check if we have some emulator library available?
 dnl ***
 if test "$OPT_SIDPLAY1" = no; then
 if test "$OPT_SIDPLAY2" = no; then
-if test "$OPT_NANOSID" = no; then
-AC_MSG_ERROR([Either libSIDPlay1, libSIDPlay2 or libNanoSID is required! Please read INSTALL for more information!])
-fi
+AC_MSG_ERROR([Either libSIDPlay1 or libSIDPlay2 is required! Please read INSTALL for more information!])
 fi
 fi
 
@@ -314,6 +257,5 @@
 	libSIDPlay 1 support          : $OPT_SIDPLAY1
 	libSIDPlay 2 support          : $OPT_SIDPLAY2
 		Included builders     : $xs_builders
-	libNanoSID support            : $OPT_NANOSID
 
 ])