diff configure.in @ 47:fd610bb817bc

Updated specfile, added new configure options and improved detections
author Matti Hamalainen <ccr@tnsp.org>
date Sat, 21 Jun 2003 20:50:02 +0000
parents 3c609b6d5a02
children b3e17bb32b21
line wrap: on
line diff
--- a/configure.in	Fri Jun 20 01:39:04 2003 +0000
+++ b/configure.in	Sat Jun 21 20:50:02 2003 +0000
@@ -16,9 +16,10 @@
 dnl ***
 dnl *** Define some templates
 dnl ***
-AH_TEMPLATE([HAVE_XMMSEXTRA],[Define if you have XMMS version 1.2.5 or later])
-AH_TEMPLATE([HAVE_SIDPLAY1],[Define if you want to use libSIDPlay 1])
-AH_TEMPLATE([HAVE_SIDPLAY2],[Define if you want to use libSIDPlay 2])
+AH_TEMPLATE([HAVE_XMMSEXTRA],[Define if you have XMMS version 1.2.5 or later and you want XMMS-SID to support some extra features.])
+AH_TEMPLATE([HAVE_UNSIGNEDPCM],[Define if your audiodevice supports _ONLY_ UNSIGNED PCM samples, otherwise leave undefined.])
+AH_TEMPLATE([HAVE_SIDPLAY1],[Define if you have and want to use libSIDPlay 1])
+AH_TEMPLATE([HAVE_SIDPLAY2],[Define if you have and want to use libSIDPlay 2])
 AH_TEMPLATE([HAVE_RESID_BUILDER],[Define if you have reSID with libSIDPlay 2])
 AH_TEMPLATE([HAVE_HARDSID_BUILDER],[Define if you have HardSID with libSIDPlay 2])
 
@@ -45,15 +46,28 @@
 dnl *** Checks for generic libraries
 dnl ***
 AM_PATH_GLIB(1.2.8,,AC_MSG_ERROR([*** GLib >= 1.2.8 not found. You either don't have GLib at all or your GLib is too old. Latest GLib can be found from Gtk+ homepages (http://www.gtk.org/)]))
+AM_PATH_GTK(1.2.8,,AC_MSG_ERROR([*** Gtk+ >= 1.2.8 not found. You either don't have Gtk+ at all or your Gtk+ is too old. Latest Gtk+ can be found from Gtk+ homepages (http://www.gtk.org/)]), gthread)
 
-AM_PATH_GTK(1.2.8,,AC_MSG_ERROR([*** Gtk+ >= 1.2.8 not found. You either don't have Gtk+ at all or your Gtk+ is too old. Latest Gtk+ can be found from Gtk+ homepages (http://www.gtk.org/)]), gthread)
+
+dnl ***
+dnl *** Check some options 
+dnl ***
+AC_ARG_WITH(unsigned-pcm,
+[
+  --with-unsigned-pcm      Prefer UNsigned PCM format for audio. Use
+                           this option if your audio hardware does not
+                           support signed format PCM samples.],
+[
+AC_DEFINE(HAVE_UNSIGNEDPCM)
+],[])
 
 
 dnl ***
 dnl *** libSIDPlay 1 options
 dnl ***
 AC_ARG_WITH(sidplay1,
-[  --with-sidplay1=PREFIX   Enable SIDPlay1 with install-PREFIX is],
+[
+  --with-sidplay1=PREFIX   Enable SIDPlay1 with install-PREFIX],
 [
 if test "$withval" = yes; then
 xs_sidplay1=yes
@@ -87,7 +101,8 @@
 dnl *** libSIDPlay 2 options
 dnl ***
 AC_ARG_WITH(sidplay2,
-[  --with-sidplay2=PREFIX   Enable SIDPlay1 with install-PREFIX is],
+[
+  --with-sidplay2=PREFIX   Enable SIDPlay2 with install-PREFIX],
 [
 if test "$withval" = yes; then
 xs_sidplay1=no
@@ -119,9 +134,7 @@
 [xs_sidplay2_library="$withval"],)
 
 
-dnl ***
 dnl *** Determine if libraries are wanted and available
-dnl ***
 OPT_SIDPLAY1="no"
 if test "$xs_sidplay1" = yes; then
 XS_PATH_LIBSIDPLAY1
@@ -157,9 +170,7 @@
 fi
 
 
-dnl ***
-dnl *** Check if we have some SIDPlay version
-dnl ***
+dnl *** Check if we have some emulator library available?
 if test "$OPT_SIDPLAY1" = no; then
 if test "$OPT_SIDPLAY2" = no; then
 AC_MSG_ERROR([Either libSIDPlay1 or libSIDPlay2 is required! Please read INSTALL for more information!])
@@ -173,10 +184,11 @@
 AC_CHECK_HEADERS([stdlib.h string.h unistd.h])
 
 AC_HEADER_STDBOOL
+AC_TYPE_SIZE_T
 AC_C_CONST
 AC_C_INLINE
-AC_TYPE_SIZE_T
 AC_C_VOLATILE
+AC_C_BIGENDIAN
 
 AC_FUNC_MALLOC
 AC_TYPE_SIGNAL