diff configure.in @ 33:9cf8092ec7d3

More improvements on configuration, updated documentation.
author Matti Hamalainen <ccr@tnsp.org>
date Sun, 08 Jun 2003 03:44:04 +0000
parents 13db37492b6d
children 3fcc147b253a
line wrap: on
line diff
--- a/configure.in	Sun Jun 08 03:16:04 2003 +0000
+++ b/configure.in	Sun Jun 08 03:44:04 2003 +0000
@@ -115,7 +115,7 @@
 if test "$xs_sidplay1" = yes; then
 XS_PATH_LIBSIDPLAY1
 if test "$xs_have_sidplay1" = yes; then
-AC_DEFINE(ENABLE_SIDPLAY1)
+AC_DEFINE(HAVE_SIDPLAY1)
 OPT_SIDPLAY1="yes"
 else
 AC_MSG_ERROR([libSIDPlay1 library and/or headers were not found!])
@@ -128,10 +128,11 @@
 LIBSIDPLAY2_REQUIRED_VERSION="2.1.0"
 XS_PATH_LIBSIDPLAY2
 if test "$xs_have_sidplay2" = yes; then
-AC_DEFINE(ENABLE_SIDPLAY2)
+AC_DEFINE(HAVE_SIDPLAY2)
 OPT_SIDPLAY2="yes"
 BUILDERS_FIND
 BUILDERS_FIND_RESID
+BUILDERS_FIND_HARDSID
 if test "$builders_available" = no; then
 AC_MSG_ERROR([No builder modules were found in the sidbuilders directory!]);
 fi
@@ -160,7 +161,7 @@
 libdir=$XMMS_INPUT_PLUGIN_DIR
 
 XMMS_TEST_VERSION($XMMS_VERSION, 1.2.5, [
-AC_DEFINE(ENABLE_XMMSEXTRA)
+AC_DEFINE(HAVE_XMMSEXTRA)
 OPT_XMMSEXTRA="yes"
 ], [
 OPT_XMMSEXTRA="no"
@@ -170,9 +171,9 @@
 dnl ***
 dnl *** Define some templates
 dnl ***
-AC_DEFINE(ENABLE_XMMSEXTRA, 0, Define to 1 if you have XMMS version 1.2.5 or later)
-AC_DEFINE(ENABLE_SIDPLAY1, 0, Define to 1 if you want to use libSIDPlay 1)
-AC_DEFINE(ENABLE_SIDPLAY2, 0, Define to 1 if you want to use libSIDPlay 2)
+AC_DEFINE(HAVE_XMMSEXTRA, 0, Define to 1 if you have XMMS version 1.2.5 or later)
+AC_DEFINE(HAVE_SIDPLAY1, 0, Define to 1 if you want to use libSIDPlay 1)
+AC_DEFINE(HAVE_SIDPLAY2, 0, Define to 1 if you want to use libSIDPlay 2)
 AC_DEFINE(HAVE_RESID_BUILDER, 0, Define to 1 if you have reSID with libSIDPlay 2)
 AC_DEFINE(HAVE_HARDSID_BUILDER, 0, Define to 1 if you have HardSID with libSIDPlay 2)